<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><script class="kxct" data-id="qv9lw720r" data-timing="async" data-version="2.0" type="text/javascript">
            window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
            (function(){
                var k=document.createElement('script');k.type='text/javascript';k.async=true;
                var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);
                k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\/controltag\//i.test(src) ? src : src === "disable" ? "" :
                    (location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=qv9lw720r";
                var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
            }());
        </script><script class="kxint" type="text/javascript">
            
            window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
            (function(){
                function retrieve(n){
                    var m, k='kxfrankly_'+n,ls=(function(){
                        try{
                            return window.localStorage;
                        }catch(e){
                            return null;
                        }
                    })();
                    if (ls) {
                        return ls[k] || "";
                    } else if (navigator.cookieEnabled) {
                        m = document.cookie.match(k+'=([^;]*)');
                        return (m && unescape(m[1])) || "";
                    } else {
                        return '';
                    }
                }
                Krux.user = retrieve('user');
                Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
            })();
            
        </script><title>To be like Mike: A Father's Day rodeo story - WAFB 9 News Baton Rouge, Louisiana News, Weather, Sports</title>
<meta name="Description" content="World champion steer wrestler Tyler Waguespack always wanted to be like Mike. And when he was little Michael Jordan may have been the biggest sports icon on the planet, but he had his eyes on his dad,"><meta name="KEYWORDS" content="WAFB TV,Louisiana,Louisiana's News Channel,TV Station,Baton Rouge news,weather"><meta name="news_keywords" content="WAFB TV,Louisiana,Louisiana's News Channel,TV Station,Baton Rouge news,weather"><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2017/06/18"><meta name="owner" content="WAFB"><meta name="wn-version" content="ContainerE-Story"><meta name="wn-build" content="news12-paywall-phase2.18"><meta name="wn-base" content="IIS05"><meta name="wnreadableurl" content="to-be-like-mike-a-fathers-day-rodeo-story"><meta property="og:title" content="To be like Mike: A Father's Day rodeo story"><meta property="og:type" content="article"><meta property="og:url" content="http://www.wafb.com/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story"><meta property="og:image" content="http://WAFB.images.worldnow.com/images/14172452_G.jpg"><meta property="og:description" content="World champion steer wrestler Tyler Waguespack always wanted to be like Mike. And when he was little Michael Jordan may have been the biggest sports icon on the planet, but he had his eyes on his dad,"><link rel="canonical" href="http://www.wafb.com/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story"><meta name="author" content="Steve Schneider"><meta name="twitter:creator" content="https://twitter.com/9sportsdirector"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="To be like Mike: A Father's Day rodeo story"><meta name="twitter:description" content="World champion steer wrestler Tyler Waguespack always wanted to be like Mike. And when he was little Michael Jordan may have been the biggest sports icon on the planet, but he had his eyes on his dad,"><meta name="twitter:image" content="http://WAFB.images.worldnow.com/images/14172452_G.jpg"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta property="fb:app_id" content="818561641490966"/><meta property="fb:admins" content="644426401" /><meta http-equiv="X-UA-Compatible" content="IE=edge" /><meta property='article:publisher' content='http://www.facebook.com/Channel9BatonRouge' /><meta property="twitter:account_id" content="14592409" /><meta name="twitter:site" content="@WAFB" /><meta name="twitter:creator" content="@WAFB" /> <!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=news12-paywall-phase2.18_7.3.9.93">
<link type="text/css" rel="stylesheet" media="all" href="http://WAFB.images.worldnow.com/interface/css/container-e.css?ver=2017-06-07%2013%3A03%3A59_7.3.9.93">

<link rel="stylesheet" media="print" href="http://content.worldnow.com/global/css/_pub/print/story.css?ver=7.3.9.93_news12-paywall-phase2.18" type="text/css"><!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=news12-paywall-phase2.18"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=news12-paywall-phase2.18"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=news12-paywall-phase2.18"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu57 UL
                    , #menu57 .wnHorizontal { background-color: #d9dad9; font-family: Arial; font-size: 11px; font-weight: 700; color: #000000; }
                #menu57 A,
                    #menu57 LI.wnOn .wnSublevel A,
                    #menu57 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 11px; font-weight: 700; color: #000000; }
                #menu57 .wnHorizontal .wnDynamic .wnMenuTypeText
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { padding-right: 15px; }
                #menu57
                        .wnLevel1 LI.wnHasSublevel .wnMiddle SPAN { background: url('http://WAFB.images.worldnow.com/images/static/gfx/nav_tridown.gif') no-repeat 98% 50%; }
                #menu57
                        .wnLevel1 LI.wnHasSublevel .wnLevel2 .wnMiddle SPAN { background: none; }
            #menu57 UL LI.wnOn { background-color: #d9dad9; color: #000000; }
                    #menu57 LI.wnOn A,
                        #menu57 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu57 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu57 .wnSublevel { background-color: #eaeaea;  }
                #menu57 .wnSublevel A { border : 1px #eaeaea solid; border-top: none; }
                        #menu57 .wnSublevel .wnFirstNode { border-top : 1px #eaeaea solid; }
                        #menu57 .wnHorizontal .wnDynamic .wnMenuTypeText .wnSublevel LI.wnHasSublevel A { padding-right: 9px; }
                #menu57 .wnSublevel LI.wnHasSublevel A { background: url('http://WAFB.images.worldnow.com/images/static/gfx/nav_tri.gif') no-repeat 98% 50%; }
                #menu57 .wnSublevel LI.wnHasSublevel .wnLevel3 A { background: none; }
            #menu57 .wnSublevel LI.wnOn { background-color: #d9dad9;  }
                    #menu57 .wnRight .wnMiddle { background: url('http://WAFB.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu57 LI.wnOn .wnMiddle { background-image: url('http://WAFB.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'WAFB',
            affiliateId : '57',
            baseUrl : 'www.wafb.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.3.9.93',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '120',mdPartnerDomain : 'http://dub.wafb.com'},
            registrationId : '104054',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://WAFB.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='news12-paywall-phase2.18';
wng_pageInfo.template='ContainerE-Story';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.containerType='S';
wng_pageInfo.ownerAffiliateName='WAFB';
wng_pageInfo.ownerAffiliateId=parseInt('57',10);
wng_pageInfo.containerId=parseInt('35692374',10);
wng_pageInfo.containerType='S';
wng_pageInfo.containerClass='story';
wng_pageInfo.contentClassification='News';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story';
wng_pageInfo.content_authors='Steve Schneider';
wng_pageInfo.headline='To be like Mike: A Father\'s Day rodeo story';
wng_pageInfo.pageTitle='To be like Mike: A Father\'s Day rodeo story - WAFB 9 News Baton Rouge, Louisiana News, Weather, Sports';
wng_pageInfo.pageTitleTag='WAFB 9 News Baton Rouge, Louisiana News, Weather, Sports';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffWAFB';
wng_pageInfo.body._class='wnContainerType-story wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        /*Ad wnsz_1 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_20 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["40"]={id:"40",wnsz:"40",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'WAFB'},width:468,height:60,wncc:"News",parent:"WNAd40",type:"dom",realvu:"",application:"printable"};
/*Ad wnsz_41 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'WAFB'},width:300,height:250,wncc:"News",parent:"WNAd43",type:"dom",realvu:"",sizes:[[300,250],[300,600]],application:"banner"};
/*Ad wnsz_44 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_46 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_47 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_49 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'WAFB'},width:300,height:250,wncc:"News",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_63 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["86"]={id:"86",wnsz:"86",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'inline',aff:'WAFB'},width:980,height:30,wncc:"News",parent:"WNAd86",type:"inline",realvu:"",sizes:[[728,90],[980,30],[970,250]],application:"banner"};
</script>
<script type="text/javascript" src="http://WAFB.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2017-06-07%2013%3A03%3A59_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/WAFB.config.js?ver=news12-paywall-phase2.18_7.3.9.93"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=news12-paywall-phase2.18_7.3.9.93"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><link href='http://fonts.googleapis.com/css?family=Open+Sans:400italic,400,700|Open+Sans+Condensed:700,300' rel='stylesheet' type='text/css'><script src="http://ftpcontent.worldnow.com/wncustom/custom/raycom/2015/custom-master.js"></script><script src="http://ftpcontent.worldnow.com/wncustom/custom/wafb/2015/custom.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/wncustom/custom/raycom/2015/custom-master.css" /><link rel="stylesheet" type="text/css" href="http://ftpcontent.worldnow.com/wncustom/custom/wafb/2015/custom.css" /></script><script src="http://ftpcontent4.worldnow.com/raycom/secondaryNav/2015/secnav-wafb.js"></script><script type="text/javascript" src="http://ftpcontent4.worldnow.com/raycom/custom/2015/raycom_custom_global.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent4.worldnow.com/raycom/custom/2015/raycom_custom_global.css" /><script type="text/javascript" src="http://ftpcontent4.worldnow.com/wafb/custom/2015/wafb-custom.js"></script><link rel="stylesheet" type="text/css" href="http://ftpcontent4.worldnow.com/wafb/custom/2015/wafb-custom.css" /><link rel='alternate' type='application/rss+xml' title='WAFB - Local News' href='http://feeds.feedburner.com/wafb/local'/><link rel='alternate' type='application/rss+xml' title='WAFB - National News' href='http://feeds.feedburner.com/wafb/nationalnews'/><link rel='alternate' type='application/rss+xml' title='WAFB - Latest Health News' href='http://feeds.feedburner.com/wafb/healthnews'/><link rel='alternate' type='application/rss+xml' title='WAFB - Healthline' href='http://feeds.feedburner.com/wafb/healthline'/><link rel='alternate' type='application/rss+xml' title='WAFB - Business News' href='http://feeds.feedburner.com/wafb/businessnews'/><link rel='alternate' type='application/rss+xml' title='WAFB - Culinary Corner' href='http://feeds.feedburner.com/wafb/culinary'/><link rel='alternate' type='application/rss+xml' title='WAFB - Hot Jobs' href='http://feeds.feedburner.com/wafb/hotjobs'/><link rel='alternate' type='application/rss+xml' title='WAFB - Crimes of the Week' href='http://feeds.feedburner.com/wafb/cotw'/><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--></head><body id="WNAffWAFB" class="wnContainerType-story wnCenterAlignment story"><!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N93ND9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-N93ND9');</script><!--End Google Tag Manager--><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>(function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-127' ,"dma":'93' ,"group":'Raycom'})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><h1>To be like Mike: A Father's Day rodeo story - WAFB 9 News Baton Rouge, Louisiana News, Weather, Sports</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/search"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google_logo.png' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://WAFB.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://WAFB.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><div id="WNColsAll" class="columnsall wnColConfig"><div id="WNMenuCol1">
<!--MENU START-->
<div id="menu57" class="wnMainMenu"><div class="wnHorizontal"><div class="wnDynamic"><div class="wnMenuTypeText"><ul class="wnLevel1" id="submenu57"><li class="wnFirstNode" id="menu57_1-C4180"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/">HOME</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu57_1-C4180"><li class="wnFirstNode" id="menu57_1_3-L501845"><span><a href="http://www.wafb.com/category/26677/your-traffic-on-wafbcom">TRAFFIC MAPS/CAMERAS</a></span></li><li class="" id="menu57_1_4-L731446"><span><a href="http://www.wafb.com/category/201700/hourly-forecast-information">Hourly Forecast Information</a></span></li><li class="" id="menu57_1_1-S35689684"><span><a href="/story/35689684/new-details-myrtle-beach-shooting-live-streamed-over-facebook-live">Myrtle Beach shooting streamed on Facebook Live</a></span></li><li class="" id="menu57_1_2-S35690534"><span><a href="/story/35690534/search-underway-after-12-year-old-girl-goes-missing-at-lower-head-dam-in-scott-county">Search underway after 12-year-old girl goes missing at Lower Head Dam in Scott County</a></span></li><li class="" id="menu57_1_5-C4491"><span><a href="/category/4491/contact-us">Contact Us</a></span></li><li class="" id="menu57_1_6-C4769"><span><a href="/category/4769/wbxh-tv">WBXH-TV</a></span></li><li class="" id="menu57_1_7-C4474"><span><a href="/category/4474/editorials">Editorials</a></span></li></ul></li><li class="" id="menu57_2-C4182"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/4182/news">NEWS</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu57_2-C4182"><li class="wnFirstNode" id="menu57_2_1-C209046"><span><a href="/category/209046/local-news">Local News</a></span></li><li class="" id="menu57_2_13-C205031"><span><a href="/category/205031/the-investigators-reports">Investigators</a></span></li><li class="" id="menu57_2_14-C212737"><span><a href="/category/212737/more-slideshows">Slideshows</a></span></li><li class="" id="menu57_2_2-C222240"><span><a href="/category/222240/regional-news">Regional News</a></span></li><li class="" id="menu57_2_3-C222241"><span><a href="/category/222241/national-news">National News</a></span></li><li class="" id="menu57_2_4-C302003"><span><a href="/category/302003/crime-stoppers">Crime Stoppers</a></span></li><li class="" id="menu57_2_5-C4488"><span><a href="/category/4488/healthline">Health</a></span></li><li class="" id="menu57_2_6-C267239"><span><a href="/category/267239/power-of-9">Power of 9</a></span></li><li class="" id="menu57_2_7-C301816"><span><a href="/category/301816/hand-it-on">Hand It On</a></span></li><li class="" id="menu57_2_8-C172753"><span><a href="/category/172753/entertainment-news">Entertainment News</a></span></li><li class="" id="menu57_2_9-C241347"><span><a href="/category/241347/video-hol">Heart of Louisiana Video</a></span></li><li class="" id="menu57_2_10-L727458"><span><a href="http://www.wafb.com/category/232209/links-mentioned">Links Mentioned</a></span></li><li class="" id="menu57_2_12-C4506"><span><a href="/category/4506/9-news-this-morning">9News This Morning</a></span></li><li class="" id="menu57_2_11-C19359"><span><a href="/category/19359/anchors-and-reporters">Anchors and Reporters</a></span></li></ul></li><li class="" id="menu57_3-C4181"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/weather">WEATHER</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu57_3-C4181"><li class="wnFirstNode" id="menu57_3_1-C137830"><span><a href="/category/137830/hurricane-tracking-center">2017 Hurricane Center</a></span></li><li class="" id="menu57_3_2-L727619"><span><a href="http://www.wafb.com/link/470963/imap">Interactive Radar</a></span></li><li class="" id="menu57_3_3-L731446"><span><a href="http://www.wafb.com/category/201700/hourly-forecast-information">Hourly Forecast Information</a></span></li><li class="" id="menu57_3_4-L5315"><span><a href="javascript:OpenWin('http://www.goes.noaa.gov||height=768,width=1024,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">Satellite Images</a></span></li><li class="" id="menu57_3_5-S23259838"><span><a href="/story/23259838/color-the-weather">Color the Weather</a></span></li><li class="" id="menu57_3_6-L329953"><span><a href="javascript:OpenWin('http://www.getagameplan.org||height=768,width=1024,location=yes,resizable=yes,scrollbars=no,toolbar=yes');">Get a Game Plan</a></span></li></ul></li><li class="" id="menu57_4-C4183"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/4183/sports">SPORTS</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu57_4-C4183"><li class="wnFirstNode" id="menu57_4_2-C208552"><span><a href="/category/208552/lsu-headlines">LSU Sports Headlines</a></span></li><li class="" id="menu57_4_3-C208553"><span><a href="/category/208553/su-headlines">SU Headlines</a></span></li><li class="" id="menu57_4_4-C208556"><span><a href="/category/208556/saints-headlines">Saints Headlines</a></span></li><li class="" id="menu57_4_5-C208557"><span><a href="/category/208557/pelicans-headlines">Pelicans Headlines</a></span></li><li class="" id="menu57_4_1-C322339"><span><a href="/category/322339/2016-warrick-dunn-award-for-the-sportsline-high-school-player-of-the-year">2016 Warrick Dunn Award </a></span></li></ul></li><li class="" id="menu57_5-C26677"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/26677/your-traffic-on-wafbcom">Traffic</a></span></span></span></span></li><li class="" id="menu57_6-C205031"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/205031/the-investigators-reports">Investigators</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu57_6-C205031"><li class="wnFirstNode" id="menu57_6_1-S31762132"><span><a href="/story/31762132/wafb-wins-murrow-award-for-investigative-reporting">WAFB wins Murrow Award for Investigative Reporting</a></span></li></ul></li><li class="" id="menu57_7-C195952"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/video">VIDEO</a></span></span></span></span></li><li class="" id="menu57_8-L769147"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="http://weekend.wafb.com">Louisiana Weekend</a></span></span></span></span></li><li class="" id="menu57_9-C291659"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/291659/lagniappe">Lagniappe</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu57_9-C291659"><li class="wnFirstNode" id="menu57_9_3-C19617"><span><a href="/category/19617/contests-and-bargains">Contests</a></span></li><li class="" id="menu57_9_4-C212737"><span><a href="/category/212737/more-slideshows">Slideshows</a></span></li><li class="" id="menu57_9_1-C186185"><span><a href="/category/186185/take-a-road-trip">Take A Road Trip</a></span></li><li class="" id="menu57_9_2-C282820"><span><a href="/category/282820/best-of-the-class-2017">Best of the Class: 2017</a></span></li><li class="" id="menu57_9_5-C113397"><span><a href="/category/113397/double-day-on-wafb">Double Day</a></span></li><li class="" id="menu57_9_6-C17576"><span><a href="/category/17576/stirrin-it-up-with-chef-john-folse">Stirrin It Up</a></span></li><li class="" id="menu57_9_7-C4492"><span><a href="/category/4492/louisiana-recipes-cajun-creole-southern-cooking">Recipes</a></span></li><li class="" id="menu57_9_8-C45732"><span><a href="/category/45732/recipe-calendars">Recipe Calendars</a></span></li></ul></li><li class="" id="menu57_10-C4493"><span class="wnLeft"><span class="wnRight"><span class="wnMiddle"><span><a href="/category/4493/about-wafb">About</a></span></span></span></span><ul class="wnLevel2 wnSublevel" id="submenu57_10-C4493"><li class="wnFirstNode" id="menu57_10_1-C11530"><span><a href="/category/11530/programming">Programming</a></span></li><li class="" id="menu57_10_2-S13817967"><span><a href="/story/13817967/the-wafb-9news-mobile-apps">The WAFB 9News Mobile Apps</a></span></li><li class="" id="menu57_10_3-S14685163"><span><a href="/story/14685163/wafb-news-internship-program">9News Internships</a></span></li><li class="" id="menu57_10_4-S584798"><span><a href="/story/584798/how-to-contact-wafb">Contact WAFB</a></span></li><li class="" id="menu57_10_5-C19359"><span><a href="/category/19359/anchors-and-reporters">Anchors and Reporters</a></span></li><li class="" id="menu57_10_6-S12183706"><span><a href="/story/12183706/closed-captioning-concerns">Closed Captioning</a></span></li><li class="" id="menu57_10_7-L589414"><span><a href="javascript:OpenWin('https://publicfiles.fcc.gov/tv-profile/wafb||height=,width=,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">WAFB FCC Public File</a></span></li><li class="" id="menu57_10_8-L704258"><span><a href="javascript:OpenWin('https://publicfiles.fcc.gov/tv-profile/wbxh-cd||height=,width=,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">WBXH FCC Public File</a></span></li><li class="" id="menu57_10_9-C131513"><span><a href="/category/131513/wafb-public-file">WAFB EEO File</a></span></li><li class="" id="menu57_10_10-C179424"><span><a href="/category/179424/advertise-on-the-wafb-network">Advertise on the WAFB Network</a></span></li><li class="" id="menu57_10_11-L663452"><span><a href="javascript:OpenWin('https://careers-raycommedia.icims.com/jobs/search?ss=1&amp;searchKeyword=&amp;searchLocation=-12802-Baton+Rouge&amp;searchCategory=||height=,width=,location=yes,resizable=yes,scrollbars=yes,toolbar=yes');">WAFB Jobs</a></span></li><li class="" id="menu57_10_12-C231300"><span><a href="/category/231300/grow-your-business">Grow Your Business</a></span></li></ul></li></ul><div class="wnClearMenu" id="clearmenu57"></div></div></div></div><div id="spacermenu57" class="wnMenuSpacer"></div></div><script type="text/javascript">
            if (window.wnMenuSetup) {
            wnMenuSetup('menu57', 
            { alignment : '', timeoutDuration : '', highlightActiveNodes : false, level1ArrowPadding : '15', levelBorderWidths : { level1 : { top : '0' , right : '0' , bottom : '0' , left : '0' } , level2 : { top : '1' , right : '1' , bottom : '1' , left : '1' } } }
        );
            }
        </script>
<!--MENU END-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNMenuCol1done');</script>
<!--END WNMenuCol1-->
<div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNAd86" class="wnad wnad86">
<script>wnad_86.load();</script></div>
<!--END wnAdSize-->
<div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div></div><!--END WNCol23Top-->
<div id="WNContainerStory" class=""><ul id="WNStoryUtils"><li class="wnSUAddThis"></li></ul><!--END WNStoryUtils-->
<div id="WNStoryHeader">
<h3 class="">To be like Mike: A Father's Day rodeo story</h3>
<time datetime="2017-06-19T03:58:19Z" class="publisheddate wn-time gmt dst-switch">2017-06-19T03:58:19Z</time><time datetime="2017-06-19T10:54:44Z" class="updateddate wn-time gmt dst-switch">2017-06-19T10:54:44Z</time><style>time.prefixdate:before{content:'Posted: ';}time.prefixdate:before{content:'Updated: ';}</style><div id="WNStoryByline" class="bylines wn-row"><div class="byline wn-row"><span class="author">By Steve Schneider, Sports</span><div class="simple"><span class="bio item"><a target="_blank" title="" href="http://www.wafb.com/Global/story.asp?S=469871">Bio</a></span><span class="email item"><a target="_self" title="" href="mailto:sschneider@wafb.com?body=http://www.wafb.com/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story">Email</a></span></div><div class="wn-anchor"><a href="#" class="connect">Connect</a><div class="connect off"><div class="bio item"><a target="_blank" title="" href="http://www.wafb.com/Global/story.asp?S=469871">Biography</a></div><div class="email item"><a target="_self" title="" href="mailto:sschneider@wafb.com?body=http://www.wafb.com/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story">sschneider@wafb.com</a></div><div class="twitter item"><a class="twitter-follow-button" data-show-count="false" data-lang="en" data-show-screen-name="false" href="https://twitter.com/9sportsdirector">Follow @9sportsdirector</a></div></div></div></div></div><div class="debug hide" data-debug="Display Size 37 attempting to load..."></div><!--DISPLAY SIZE 37: -->
<div id="WNDS37" class="wnDS37 wnDSContainer-standard wnDS">
<div class="wnDSItems-standard">
<style type="text/css">
#divWNInfoPane201079 {top:360px; left:0px; position:absolute}
#divWNHeadline201079 {top:0px; left:0px; position:absolute}
#divWNImageCanvas201079 {top:25px; left:0px; position:absolute}
#divWNImageGallery201079 {top:388px; left:0px; position:absolute}
#divWNImageGallery201079 {background-color: #fff}
#divWNImageGallery201079 ul, #divWNImageGallery201079 a, #divWNImageGallery201079 a:visited { color:#fff; }
#divWNImageCanvas201079_addThis {top:46px; left:20px; position:absolute; z-index: -1; background-color: transparent; visibility: hidden; }
#divWNImageCanvas201079_adDiv {top:26px; left:1px; position:absolute; z-index: -1; background-color: #fff; overflow: hidden; visibility: hidden; width:598px; height:336px;}
#divWNImageCanvas201079_adDiv_close, #divWNImageCanvas201079_adDiv_close div {width: 300px; height: 20px; left: 150px; top:24px; position: absolute; z-index: 3; background-color: #DDD; text-align: right; color: #444; font-size: 11px; line-height: 18px; font-family: verdana;}
#divWNImageCanvas201079_adDiv_close div {left: 0px; top: 0px;}
#divWNImageCanvas201079_adDiv_ad {z-index: 2; width: 300px; height: 250px; left:150px; top:44px; position:absolute; overflow: hidden;}
#divWNWidgetsContainer201079 {position:relative}
</style>

<div id="divWNWidgetsContainer201079" style="overflow:hidden;height:458px;width:600px;">
<div id="divWNInfoPane201079"></div>
<div id="divWNHeadline201079"></div>
<div id="divWNImageCanvas201079"></div>
<div id="divWNImageCanvas201079_adDiv">
    <div id="divWNImageCanvas201079_adDiv_close">        <div style="background-color: transparent; text-align: center;">ADVERTISEMENT</div>    </div>
    <div id="divWNImageCanvas201079_adDiv_ad"></div>
</div>
<div id="divWNImageCanvas201079_addThis">
    <div><a href="http://www.addthis.com/bookmark.php?v=250&pub=xa-4a6f307d7c62c8a7" 
            onmouseover="return addthis_open(this, '', 'http://www.wafb.com/global/slideshow.asp?widgetId=' + addThisWNDynamicWidgetId, 'Slideshow')" 
            onmouseout="addthis_close()" onclick="return addthis_sendto()"><img src="http://s7.addthis.com/static/btn/sm-share-en.gif" width="83" height="16" alt="Bookmark and Share" style="border:0"/></a></div>
</div>
<div id="divWNImageGallery201079">
<ul>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=12">Tyler Waguspack and his father</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=10">Tyler Waguspack</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=11">Tyler Waguspack rodeo</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=17">Tyler Waguspack childhood picture</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=15">Dad looking on</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=13">National Finals Rodeo 2016</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=14">WNFR All Around Champion 2016</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=19">tyler-waguspack-7</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=18">tyler-waguspack-9</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=16">tyler-waguspack-10</a></li>
   <li><a href="http://www.wafb.com/global/slideshow.asp?widgetId=201079&slideshowImageId=9">end slideshows</a></li>
</ul>
</div>

</div>

<script type="text/javascript">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</script>
<noscript>Slideshow: SLIDESHOW: To be like Mike: A Father's Day rodeo story</noscript><div id="divWNStoryVideoDS37" style="&#xA;          height: 355px; overflow: hidden; position: relative;&#xA;        "><div id="divWNGalleryDS37" style="&#xA;            top: 354px; z-index: 1000; position: absolute;&#xA;          "></div><div id="divWNVideoCanvasDS37" style="position: absolute; top: 0px;"></div><script type="text/javascript">
          var widgetVideoCanvasDS37 = new WNVideoWidget("WNVideoCanvas2", "divWNVideoCanvasDS37", "DS37");
          widgetVideoCanvasDS37.SetStylePackage("flatlight");
          widgetVideoCanvasDS37.SetSkin(CANVAS_SKINS.flat.ebony);
          widgetVideoCanvasDS37.SetWidth("630");
          widgetVideoCanvasDS37.SetHeight("355");
          widgetVideoCanvasDS37.SetVariable("landingPage", document.location.href);
          widgetVideoCanvasDS37.SetVariable("clipId", "13423515");
          widgetVideoCanvasDS37.SetVariable("transportShareButtons", "cc");
          widgetVideoCanvasDS37.SetVariable("controlsType", "fixed");
          

            try {
                if(wn.video.site.enablestorypageautoplay) {
                    widgetVideoCanvasDS37.SetVariable('isAutoStart', 'true');
                }
            }
            catch(e) {}

          widgetVideoCanvasDS37.RenderWidget();
          </script></div></div><!--END wnDSItems-->
</div><!--
                END wnDS37-->
</div><!--END WNStoryHeader-->
<div id="WNStoryRelatedBox" class="wnRight" WNCollapse="true"><div class="debug hide" data-debug="Display Size 20 attempting to load..."></div><div class="wnStoryBodyGraphic wnImageWidth-180"><img src="http://WAFB.images.worldnow.com/images/14172452_G.jpg" alt="" title="" border="0" width="180">
</div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNStoryRelatedBoxdone');</script>
<!--END WNStoryRelatedBox-->
<div id="WNStoryBody" class=" withRelated right"><span id="WNStoryDateline">BATON ROUGE, LA -
            </span><p>World champion steer wrestler Tyler Waguespack always wanted to be like Mike. And when he was little Michael Jordan may have been the biggest sports icon on the planet, but he had his eyes on his dad, Mike Waguespack a bull dogger himself.</p><p>&quot;Whenever I'd go to the rodeos with my Dad, I mean whenever I was sitting on the fence, a little kid watching him compete, I mean that's who I wanted to win,&quot; said Tyler who started as a toddler. &quot;I wanted to be like him, or better!&quot;<br /><br />At age 26 Waguespack is now the biggest name in his specialty, but the Gonzales native is definitely not the biggest competitor, despite taking home the title at the 2016 National Finals Rodeo in Las Vegas last December.</p><p>&quot;When we started Tyler he was small,&quot; said Waguespack. &quot;He's still small compared to most of these guys he competes against. I told him then (when he was a kid) 'We're going to teach you small, but you can't cut any corners. You have to do it right.&quot;<br /><br />Tyler says his father, who didn't stop steer wrestling himself until he was 55, has worked just as hard as he has to make his dream of becoming a champion a reality. And he's gone to extremes at times.</p><p>&quot;He's been behind me a hundred percent of the way. Anything I needed, any help he could give me. I can still remember the first time practicing here with Dad. We had just a little bitty small calf. My dad taped PVC pipe across his head so he had enough horns that I could throw him,&quot; recalls Tyler.</p><p>And after practicing every day for two months, he earned the gold buckle at the NFR, symbolic of the Top Gun in professional rodeo for 2016, with his dad there with him every step of the way.</p><p><em>Copyright 2017&nbsp;</em><a href="http://www.wafb.com/" target="_blank"><em>WAFB</em></a><em>. All rights reserved.</em></p></div><!--END WNStoryBody-->
<div id="wnSocialToolsSection"><div id="WNMobdub"></div></div>
<div class="wnClear"></div></div><!--END WNContainerStory-->
<div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size -20 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div></div><!--END WNCol23Bottom-->
</div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 8-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><!--Start of Display Size: Headline Box - Col 4 (78)--><div class="wnBlock displaySize displaySizeId78 headlineBox" id="DisplaySizeId78"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text abridgedHeadline">Local News</span><a class="wnContent more enabled" href="/category/209046/local-news"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem advertisement">
</li><li class="wnItem feature News story priority-1 odd displaySizeId-7 odd-7"><meta content="News"><meta content="2017-06-19 03:58:19"><h4 class="wnContent headline"><a href="/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story"><span class="text">To be like Mike: A Father's Day rodeo story</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story"><span class="text">To be like Mike: A Father's Day rodeo story</span></a></h4><div class="wnContent summaryImage left width90"><a href="/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/14172452_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/14172452_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>World champion steer wrestler Tyler Waguespack always wanted to be like Mike. And when he was little Michael Jordan may have been the biggest sports icon on the planet, but he had his eyes on his dad,</p></span><a class="more" href="/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>World champion steer wrestler Tyler Waguespack always wanted to be like Mike. And when he was little Michael Jordan may have been the biggest sports icon on the planet, but he had his eyes on his dad, Mike Waguespack a bull dogger himself. &quot;Whenever I'd go to the rodeos with my Dad, I mean whenever I was sitting on the fence, a little kid watching him compete, I mean that's who I wanted to win,&quot; s</p></span><a class="more" href="/story/35692374/to-be-like-mike-a-fathers-day-rodeo-story"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-2 even displaySizeId-7 even-7"><meta content="News"><meta content="2017-06-19 03:47:25"><h4 class="wnContent headline"><a href="/story/35692350/donors-father-travels-across-the-country-to-hear-daughters-heartbeat"><span class="text">Donor's father travels across the country to hear daughter's heartbeat</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35692350/donors-father-travels-across-the-country-to-hear-daughters-heartbeat"><span class="text">Donor's father travels across the country to hear daughter's heartbeat</span></a></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, June 18 2017 11:50 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 03:50:17 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35692350/donors-father-travels-across-the-country-to-hear-daughters-heartbeat"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/14171158_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35692350/donors-father-travels-across-the-country-to-hear-daughters-heartbeat"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/14171158_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Bill Conner is on a healing journey.</p></span><a class="more" href="/story/35692350/donors-father-travels-across-the-country-to-hear-daughters-heartbeat"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Bill Conner is on a healing journey.</p></span><a class="more" href="/story/35692350/donors-father-travels-across-the-country-to-hear-daughters-heartbeat"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-3 odd displaySizeId-7 odd-7"><meta content="News"><meta content="2017-06-18 23:43:00"><h4 class="wnContent headline"><a href="/story/35691798/with-a-fiscal-cliff-on-the-horizon-will-another-special-session-be-worthwhile"><span class="text">With a fiscal cliff on the horizon, will another special session be worthwhile?</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35691798/with-a-fiscal-cliff-on-the-horizon-will-another-special-session-be-worthwhile"><span class="text">With a fiscal cliff on the horizon, will another special session be worthwhile?</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, June 18 2017 11:06 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 03:06:02 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35691798/with-a-fiscal-cliff-on-the-horizon-will-another-special-session-be-worthwhile"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/14170901_G.jpg" title="Source: WAFB" alt="Source: WAFB"></a><span class="caption left width90"><span class="text">Source: WAFB</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35691798/with-a-fiscal-cliff-on-the-horizon-will-another-special-session-be-worthwhile"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/14170901_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Louisiana is barreling toward yet another budget mess, but the governor says he wonders if another special session would really amount to just a waste of time.</p></span><a class="more" href="/story/35691798/with-a-fiscal-cliff-on-the-horizon-will-another-special-session-be-worthwhile"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Louisiana is barreling toward yet another budget mess, but the governor says he wonders if another special session would really amount to just a waste of time.</p></span><a class="more" href="/story/35691798/with-a-fiscal-cliff-on-the-horizon-will-another-special-session-be-worthwhile"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-4 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2017-06-19 02:49:56"><h4 class="wnContent headline"><a href="/story/35692252/hurricane-center-monitoring-two-areas-of-low-pressure"><span class="text">Hurricane center monitoring two areas of low pressure</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35692252/hurricane-center-monitoring-two-areas-of-low-pressure"><span class="text">Hurricane center monitoring two areas of low pressure</span></a></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, June 18 2017 10:49 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 02:49:56 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35692252/hurricane-center-monitoring-two-areas-of-low-pressure"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/13213023_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35692252/hurricane-center-monitoring-two-areas-of-low-pressure"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/13213023_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Governor&rsquo;s Office of Homeland Security and Emergency Preparedness (GOHSEP) urges everyone to be aware of two areas of low pressure for possible tropical development.</p> </span><a class="more" href="/story/35692252/hurricane-center-monitoring-two-areas-of-low-pressure"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Governor&rsquo;s Office of Homeland Security and Emergency Preparedness (GOHSEP) urges everyone to be aware of two areas of low pressure for possible tropical development.</p></span><a class="more" href="/story/35692252/hurricane-center-monitoring-two-areas-of-low-pressure"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-5 odd displaySizeId-7 odd-7 collapsed last"><meta content="News"><meta content="2017-06-19 01:13:33"><h4 class="wnContent headline"><a href="/story/35692033/driver-loses-control-crashes-into-ditch-in-central"><span class="text">Driver loses control, crashes into ditch in Central</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35692033/driver-loses-control-crashes-into-ditch-in-central"><span class="text">Driver loses control, crashes into ditch in Central</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="wnContent summaryImage left width90"><a href="/story/35692033/driver-loses-control-crashes-into-ditch-in-central"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/14170577_G.jpg" title="Source: CFD Facebook" alt="Source: CFD Facebook"></a><span class="caption left width90"><span class="text">Source: CFD Facebook</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35692033/driver-loses-control-crashes-into-ditch-in-central"><img border="0" width="90" data-path="http://WAFB.images.worldnow.com/images/14170577_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A driver lost control of their vehicle Sunday evening, ending up off the road and in a creek.</p> </span><a class="more" href="/story/35692033/driver-loses-control-crashes-into-ditch-in-central"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A driver lost control of their vehicle Sunday evening, ending up off the road and in a creek.</p></span><a class="more" href="/story/35692033/driver-loses-control-crashes-into-ditch-in-central"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId78');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Headline Box - Col 4 (78)--><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div><!--Start of Display Size: Nested Category - Col 4 (68)--><div class="wnBlock displaySize displaySizeId68 nestedCategory" id="DisplaySizeId68"><ul class="wnGroup contentGroup odd collapsible closed last"><li class="wnItem header"><h3><span class="text sectionTitle">Trending Stories</span><span class="text abridgedHeadline">Trending Stories</span><a class="wnContent more enabled" href="/category/306255/trending-stories"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature NewsAPNational story priority-1 odd displaySizeId-7 odd-7"><meta content="News - AP-National"><meta content="2017-06-18 06:03:42"><h4 class="wnContent headline"><a href="/story/35689601/mother-son-tried-to-save-navy-shipmates-after-collision"><span class="text">Mother: Son tried to save Navy shipmates after collision</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35689601/mother-son-tried-to-save-navy-shipmates-after-collision"><span class="text">Mother: Son tried to save Navy shipmates after collision</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp publisheddate">Posted: </label><span class="wnContent timestamp servertime">Sunday, June 18 2017 2:03 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-18 06:03:42 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 5:16 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 09:16:09 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35689601/mother-son-tried-to-save-navy-shipmates-after-collision"><img border="0" width="90" data-path="http://APMOBILE.images.worldnow.com/images/14167861_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35689601/mother-son-tried-to-save-navy-shipmates-after-collision"><img border="0" width="90" data-path="http://APMOBILE.images.worldnow.com/images/14167861_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>The commander of the U.S. Navy's 7th Fleet says that search and rescue efforts are over for the seven sailors missing after a destroyer collided with a merchant ship in waters off Japan.</p> </span><a class="more" href="/story/35689601/mother-son-tried-to-save-navy-shipmates-after-collision"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The commander of the U.S. Navy's 7th Fleet says that search and rescue efforts are over for the seven sailors missing after a destroyer collided with a merchant ship in waters off Japan.</p></span><a class="more" href="/story/35689601/mother-son-tried-to-save-navy-shipmates-after-collision"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsAPNational story priority-2 even displaySizeId-7 even-7"><meta content="News - AP-National"><meta content="2017-06-19 08:35:13"><h4 class="wnContent headline"><a href="/story/35693082/japan-investigates-delay-in-reporting-us-navy-ship-collision"><span class="text">Japan investigates delay in reporting US Navy ship collision</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35693082/japan-investigates-delay-in-reporting-us-navy-ship-collision"><span class="text">Japan investigates delay in reporting US Navy ship collision</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp publisheddate">Posted: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 4:35 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 08:35:13 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 8:17 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 12:17:39 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35693082/japan-investigates-delay-in-reporting-us-navy-ship-collision"><img border="0" width="90" data-path="http://APMOBILE.images.worldnow.com/images/14171796_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35693082/japan-investigates-delay-in-reporting-us-navy-ship-collision"><img border="0" width="90" data-path="http://APMOBILE.images.worldnow.com/images/14171796_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text">Japan's coast guard is investigating why it took nearly an hour for a deadly collision between a U.S. Navy destroyer and a container ship to be reported.</span><a class="more" href="/story/35693082/japan-investigates-delay-in-reporting-us-navy-ship-collision"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Japan's coast guard is investigating why it took nearly an hour for a deadly collision between a U.S. Navy destroyer and a container ship to be reported.</span><a class="more" href="/story/35693082/japan-investigates-delay-in-reporting-us-navy-ship-collision"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station50 story priority-3 odd displaySizeId-7 odd-7"><meta content="Station 50"><meta content="2017-06-19 09:10:03"><h4 class="wnContent headline"><a href="/story/35693189/two-atlantic-tropical-systems-may-develop-into-named-storms"><span class="text">Two Atlantic tropical systems may develop into named storms</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35693189/two-atlantic-tropical-systems-may-develop-into-named-storms"><span class="text">Two Atlantic tropical systems may develop into named storms</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp publisheddate">Posted: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 5:10 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 09:10:03 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 7:46 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 11:46:21 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35693189/two-atlantic-tropical-systems-may-develop-into-named-storms"><img border="0" width="90" data-path="http://RAYCOMGROUP.images.worldnow.com/images/14171887_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35693189/two-atlantic-tropical-systems-may-develop-into-named-storms"><img border="0" width="90" data-path="http://RAYCOMGROUP.images.worldnow.com/images/14171887_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Two storms are brewing in the Atlantic basin&nbsp;and could become named storms within the next two days.</p> </span><a class="more" href="/story/35693189/two-atlantic-tropical-systems-may-develop-into-named-storms"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Two storms are brewing in the Atlantic basin&nbsp;and could become named storms within the next two days.</p></span><a class="more" href="/story/35693189/two-atlantic-tropical-systems-may-develop-into-named-storms"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-4 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2017-06-18 08:11:51"><h4 class="wnContent headline"><a href="/story/35689684/new-details-myrtle-beach-shooting-live-streamed-over-facebook-live"><span class="text">Myrtle Beach shooting streamed on Facebook Live</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35689684/new-details-myrtle-beach-shooting-live-streamed-over-facebook-live"><span class="text">Myrtle Beach shooting streamed on Facebook Live</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 7:56 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 11:56:38 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35689684/new-details-myrtle-beach-shooting-live-streamed-over-facebook-live"><img border="0" width="90" data-path="http://WMBF.images.worldnow.com/images/14168305_G.png" title="(Source: Bubba Hinson)" alt="(Source: Bubba Hinson)"></a><span class="caption left width90"><span class="text">(Source: Bubba Hinson)</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35689684/new-details-myrtle-beach-shooting-live-streamed-over-facebook-live"><img border="0" width="90" data-path="http://WMBF.images.worldnow.com/images/14168305_G.png"></a></div><div class="wnContent summary abridged"><span class="text"><p>Myrtle Beach police&nbsp;responded to the area of Fifth Avenue North and Ocean Blvd Sunday morning around 12:15 a.m. after receiving calls about&nbsp;a large crowd.&nbsp;</p></span><a class="more" href="/story/35689684/new-details-myrtle-beach-shooting-live-streamed-over-facebook-live"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Myrtle Beach police&nbsp;responded to the area of Fifth Avenue North and Ocean Blvd Sunday morning around 12:15 a.m. after receiving calls about&nbsp;a large crowd.&nbsp;</p></span><a class="more" href="/story/35689684/new-details-myrtle-beach-shooting-live-streamed-over-facebook-live"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature NewsInvestigate story priority-5 odd displaySizeId-7 odd-7 collapsed"><meta content="News - Investigate"><meta content="2017-06-13 21:18:37"><h4 class="wnContent headline"><a href="/story/35656740/alleged-cleveland-facebook-scam-costs-moms-200000-across-us-a-carl-monday-investigation"><span class="text">Alleged Cleveland Facebook scam costs moms $200,000+ across U.S.: A Carl Monday investigation</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35656740/alleged-cleveland-facebook-scam-costs-moms-200000-across-us-a-carl-monday-investigation"><span class="text">Alleged Cleveland Facebook scam costs moms $200,000+ across U.S.: A Carl Monday investigation</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Friday, June 16 2017 3:44 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-16 19:44:08 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35656740/alleged-cleveland-facebook-scam-costs-moms-200000-across-us-a-carl-monday-investigation"><img border="0" width="90" data-path="http://woio.images.worldnow.com/images/14131152_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35656740/alleged-cleveland-facebook-scam-costs-moms-200000-across-us-a-carl-monday-investigation"><img border="0" width="90" data-path="http://woio.images.worldnow.com/images/14131152_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Hundreds of moms in dozens of cities say they've been scammed out of more than $200,000 by a 23-year-old woman living in public housing in Cleveland.&nbsp;</p></span><a class="more" href="/story/35656740/alleged-cleveland-facebook-scam-costs-moms-200000-across-us-a-carl-monday-investigation"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Hundreds of moms in dozens of cities say they've been scammed out of more than $200,000 by a 23-year-old woman living in public housing in Cleveland.</p></span><a class="more" href="/story/35656740/alleged-cleveland-facebook-scam-costs-moms-200000-across-us-a-carl-monday-investigation"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-6 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2017-06-17 01:53:08"><h4 class="wnContent headline"><a href="/story/35685860/woman-punched-in-the-face-40-times-video-of-assault-posted-to-social-media"><span class="text">Woman punched in the face 40 times, video of assault posted to social media</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35685860/woman-punched-in-the-face-40-times-video-of-assault-posted-to-social-media"><span class="text">Woman punched in the face 40 times, video of assault posted to social media</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Friday, June 16 2017 9:53 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-17 01:53:08 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35685860/woman-punched-in-the-face-40-times-video-of-assault-posted-to-social-media"><img border="0" width="90" data-path="http://WXIX.images.worldnow.com/images/14162841_G.jpg" title="Shakurra Payne" alt="Shakurra Payne"></a><span class="caption left width90"><span class="text">Shakurra Payne</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35685860/woman-punched-in-the-face-40-times-video-of-assault-posted-to-social-media"><img border="0" width="90" data-path="http://WXIX.images.worldnow.com/images/14162841_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Shakurra Payne is in the Hamilton County Jail after being accused of beating a Kentucky woman. Court records show she hit the victim 40 times in the face.</p> </span><a class="more" href="/story/35685860/woman-punched-in-the-face-40-times-video-of-assault-posted-to-social-media"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Shakurra Payne is in the Hamilton County Jail after being accused of beating a Kentucky woman. Court records show she hit the victim 40 times in the face.</p></span><a class="more" href="/story/35685860/woman-punched-in-the-face-40-times-video-of-assault-posted-to-social-media"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-7 odd displaySizeId-7 odd-7 collapsed"><meta content="News"><meta content="2017-06-17 22:34:49"><h4 class="wnContent headline"><a href="/story/35688680/exclusive-charges-being-filed-after-mom-discovers-son-locked-in-daycare-closet"><span class="text">First on 9: Charges being filed after mom discovers son locked in daycare closet</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35688680/exclusive-charges-being-filed-after-mom-discovers-son-locked-in-daycare-closet"><span class="text">First on 9: Charges being filed after mom discovers son locked in daycare closet</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, June 18 2017 6:40 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-18 22:40:38 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35688680/exclusive-charges-being-filed-after-mom-discovers-son-locked-in-daycare-closet"><img border="0" width="90" data-path="http://wtvm.images.worldnow.com/images/14166291_G.jpg" title="(Source: WTVM/Brandon Etheredge)" alt="(Source: WTVM/Brandon Etheredge)"></a><span class="caption left width90"><span class="text">(Source: WTVM/Brandon Etheredge)</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35688680/exclusive-charges-being-filed-after-mom-discovers-son-locked-in-daycare-closet"><img border="0" width="90" data-path="http://wtvm.images.worldnow.com/images/14166291_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A mother in Phenix City is looking for answers after she says her son was mistreated at a local daycare. &nbsp;</p> </span><a class="more" href="/story/35688680/exclusive-charges-being-filed-after-mom-discovers-son-locked-in-daycare-closet"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A mother in Phenix City is looking for answers after she says her son was mistreated at a local daycare. &nbsp;</p></span><a class="more" href="/story/35688680/exclusive-charges-being-filed-after-mom-discovers-son-locked-in-daycare-closet"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-8 even displaySizeId-7 even-7 collapsed"><meta content="News"><meta content="2017-06-18 01:07:25"><h4 class="wnContent headline"><a href="/story/35689074/father-calls-son-a-hero-after-deadly-electrical-accident-at-put-in-bay"><span class="text">Father calls son a hero after deadly electrical accident at Put-In-Bay</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35689074/father-calls-son-a-hero-after-deadly-electrical-accident-at-put-in-bay"><span class="text">Father calls son a hero after deadly electrical accident at Put-In-Bay</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, June 18 2017 4:18 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-18 20:18:22 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35689074/father-calls-son-a-hero-after-deadly-electrical-accident-at-put-in-bay"><img border="0" width="90" data-path="http://woio.images.worldnow.com/images/14166893_G.jpg" title="Evan Currie" alt="Evan Currie"></a><span class="caption left width90"><span class="text">Evan Currie</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35689074/father-calls-son-a-hero-after-deadly-electrical-accident-at-put-in-bay"><img border="0" width="90" data-path="http://woio.images.worldnow.com/images/14166893_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>A heartbreaking story this Father's Day weekend. A dad telling how his son died a hero at Put-In-Bay by saving the lives of family members after a freak accident electrified the water around their boat. The Currie family from Dublin, right outside Columbus, Ohio, was docked&nbsp;Friday night&nbsp;in Put-In-Bay at Miller Marina. Their dog Daisy ended up in the water and that's when something went horribly wrong. Jeff Currie's two sons, jumped in to help save the dog.&nbsp;Currie say...</p></span><a class="more" href="/story/35689074/father-calls-son-a-hero-after-deadly-electrical-accident-at-put-in-bay"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>A heartbreaking story this Father's Day weekend. A dad telling how his son died a hero at Put-In-Bay by saving the lives of family members after a freak accident electrified the water around their boat. The Currie family from Dublin, right outside Columbus, Ohio, was docked&nbsp;Friday night&nbsp;in Put-In-Bay at Miller Marina. Their dog Daisy ended up in the water and that's when something went horribly wrong. Jeff Currie's two sons, jumped in to help save the dog.&nbsp;Currie say...</p></span><a class="more" href="/story/35689074/father-calls-son-a-hero-after-deadly-electrical-accident-at-put-in-bay"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station50 story priority-9 odd displaySizeId-7 odd-7 collapsed"><meta content="Station 50"><meta content="2017-06-19 10:43:35"><h4 class="wnContent headline"><a href="/story/35693729/boy-accidentally-jabs-self-with-hypodermic-needle-found-at-park"><span class="text">Boy accidentally jabs self with hypodermic needle found at park</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35693729/boy-accidentally-jabs-self-with-hypodermic-needle-found-at-park"><span class="text">Boy accidentally jabs self with hypodermic needle found at park</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp publisheddate">Posted: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 6:58 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 10:58:11 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 6:58 AM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 10:58:11 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35693729/boy-accidentally-jabs-self-with-hypodermic-needle-found-at-park"><img border="0" width="90" data-path="http://RAYCOMGROUP.images.worldnow.com/images/14172432_G.jpg"></a></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35693729/boy-accidentally-jabs-self-with-hypodermic-needle-found-at-park"><img border="0" width="90" data-path="http://RAYCOMGROUP.images.worldnow.com/images/14172432_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>Six-year-old Skyler Anderson said he was walking along a grassy area of a park trail when he saw a needle, picked it up and accidentally pricked himself.</p></span><a class="more" href="/story/35693729/boy-accidentally-jabs-self-with-hypodermic-needle-found-at-park"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Six-year-old Skyler Anderson said he was walking along a grassy area of a park trail when he saw a needle, picked it up and accidentally pricked himself.</p></span><a class="more" href="/story/35693729/boy-accidentally-jabs-self-with-hypodermic-needle-found-at-park"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature News story priority-10 even displaySizeId-7 even-7 collapsed last"><meta content="News"><meta content="2017-06-18 16:46:56"><h4 class="wnContent headline"><a href="/story/35690534/search-underway-after-12-year-old-girl-goes-missing-at-lower-head-dam-in-scott-county"><span class="text">Search underway after 12-year-old girl goes missing at Lower Head Dam in Scott County</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35690534/search-underway-after-12-year-old-girl-goes-missing-at-lower-head-dam-in-scott-county"><span class="text">Search underway after 12-year-old girl goes missing at Lower Head Dam in Scott County</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate updateddate"><label class="wnContent timestamp">Updated: </label><span class="wnContent timestamp servertime">Sunday, June 18 2017 11:25 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 03:25:40 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35690534/search-underway-after-12-year-old-girl-goes-missing-at-lower-head-dam-in-scott-county"><img border="0" width="90" data-path="http://wlbt.images.worldnow.com/images/14171029_G.jpg" title="Source: WLBT" alt="Source: WLBT"></a><span class="caption left width90"><span class="text">Source: WLBT</span></span></div><div class="wnContent summaryImage abridged left width90"><a href="/story/35690534/search-underway-after-12-year-old-girl-goes-missing-at-lower-head-dam-in-scott-county"><img border="0" width="90" data-path="http://wlbt.images.worldnow.com/images/14171029_G.jpg"></a></div><div class="wnContent summary abridged"><span class="text"><p>There will be people stationed to be on the lookout overnight, and boats will go back out early tomorrow morning.</p></span><a class="more" href="/story/35690534/search-underway-after-12-year-old-girl-goes-missing-at-lower-head-dam-in-scott-county"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>There will be people stationed to be on the lookout overnight, and boats will go back out early tomorrow morning.</p></span><a class="more" href="/story/35690534/search-underway-after-12-year-old-girl-goes-missing-at-lower-head-dam-in-scott-county"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnItem toggle" data-number="3"><a class="text control open"> </a><a class="text control close"> </a><div class="wnClear"></div></div><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId68');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Nested Category - Col 4 (68)--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
<div id="WNFooter"><div id="WNCopyrightAlignment"><div id="WNCopyright"><table border="0" cellpadding="0" cellspacing="0"><tr><td style="vertical-align:top;"><a href="http://www.franklyinc.com" target="_blank"><img class="wnFooter" src="http://WAFB.images.worldnow.com/images/static/container-e/wn_powerby.gif" alt="Powered by Frankly" border="0"><img style="display:none;" class="wnFooter printable" src="http://images.worldnow.com/global/images/static/container-e/wn_powerby_printable.gif" alt="Powered by WorldNow" border="0"></a></td><td style="vertical-align:middle;"><div class="wnCopyrightText"><div id="CDEV-footer">
	<div class="top"> 
		<div class="search-box">
			<div class="wnSearchBox" id="WNSearchBox-bottom"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/Global/searchresults.asp"><span>Can't Find Something? </span><input type="text" class="wnQueryText" name="qu" size="20" value="" placeholder="Search For It Here"><input type="submit" class="wnSubmit" value="Search"></form></div>			
		</div>
		<div class="station-info">
			<div class="logo"><img src="http://wafb.images.worldnow.com/images/8801682_G.png" width="174" height="124" border="0" /></div>
			<div class="contact">
				<div>844 Government Street<br>Baton Rouge, LA 70802</div>
				<div>(225) 383-9999</div>
			</div>
			<div class="fcc">
				<div><a href="https://publicfiles.fcc.gov/tv-profile/wafb">WAFB FCC Public File</a></div>
				<div><a href="
https://publicfiles.fcc.gov/tv-profile/wbxh-cd">WBXH FCC Public File</a></div>				
				<a href="mailto:publicfile@wafb.com">publicfile@wafb.com</a>
				<div>(225) 215-4703</div>
				<a href="/category/131513/wafb-public-file">EEO Report</a>
				<a href="/story/12183706/closed-captioning-concerns">Closed Captioning</a>
			</div>			
		</div>
	</div>
	<div class="footer-main-nav"> 
		<ul class="link-group">
			<!--<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>
			<li><a href="#">News Now Link</a></li>-->
		</ul>
	</div>	
	<div class="news-link"> 
		<ul class="link-group">
			<li><a href="http://www.ktre.com/category/241993/texas-news-now">Texas News Now</a></li>
		</ul>
	</div>	
	<div class="bottom">
		<div class="copyrightText">
			<a id="wnLogo" href="http://www.worldnow.com"><img src="http://ftpcontent.worldnow.com/wncorp/logos/worldnow_white.png" id="wn"></a>
        	<div class="text">
				All content &copy; Copyright 2000 - 2017 Raycom Media. All Rights Reserved. For more information on this site, please read our <a href="/story/8774923/privacy-policy">Privacy Policy</a>, and <a href="/story/8775106/terms-of-service">Terms of Service</a>, and <a class="adchoice" href="//www.aboutads.info/choices" target="policy">Ad Choices</a>.
        	</div>
        	<div class="clear"></div>       
		</div>	
	</div>
</div></div></td></tr></table></div><div class="wnClear"></div></div><div class="wnClear"></div><!--END WNCopyright--></div><div id="WNFooterScripts"></div><!--END WNFooter-->
<!--
                Page Include: BODY--><script src="http://ftpcontent4.worldnow.com/raycom/js/global-footer.js"></script><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>