<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"rLHRca29un8L8r",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"wafb"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "wafb/web/sports/national",
    "authors": [
                  
                    {
                      "_id": "",
                      "name": "BRIAN MAHONEY",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2018/11/13/nets-say-levert-could-return-foot-injury-this-season/",
    "contentId": "MP5YZTV6IJATFOYV5SE2LSEVWI",
    "contentName": "Nets say LeVert could return from foot injury this season",
    "contentOwner": "raycom",
    "contentTags":  [
                  
                ],
    "contentType": "story",
    "datePublished": "2018-11-13T20:03:09.415Z",
    "description": "Brooklyn Nets say Caris LeVert won't need surgery for what appeared to be severe foot injury and could return this season",
    "hasVideo": "false",
    "metaDescription": "Brooklyn Nets say Caris LeVert won't need surgery for what appeared to be severe foot injury and could return this season",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "National",
                            "_id": "/sports/national",
                            "path": "/sports/national",
                          }
                        
                      ,
    "publishedDay": "13",
    "publishedMonth": "11",
    "publishedYear": "2018",
    "stationName": "wafb",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="Cv57GIIPSYxvcGtpP7lYKjsgzehmCPjuPrvIt2PzbwQ"/> <title>Nets say LeVert could return from foot injury this season</title> <meta name="keywords" content="BKN,, Nets, LeVert Injured"> <meta name="news_keywords" content="BKN,, Nets, LeVert Injured"/> <meta name="date" content="2018-11-13T20:03:09.415Z"/> <meta itemprop="description" name="description" content="Brooklyn Nets say Caris LeVert won't need surgery for what appeared to be severe foot injury and could return this season"/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="/2018/11/13/nets-say-levert-could-return-foot-injury-this-season/"> <meta name="twitter:title" content="Nets say LeVert could return from foot injury this season"/> <meta name="twitter:image" content="http://www.wafb.com/resizer/bYoBad2j0tmWSHYQhoBm8ylbgjU=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/AL37UPABCVGI5BPWG6DVUGYWHY.jpg"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="Brooklyn Nets say Caris LeVert won't need surgery for what appeared to be severe foot injury and could return this season"/> <meta name="twitter:site" content="@WAFB"/> <meta name="twitter:creator" content="@WAFB"> <meta property="og:url" content="/2018/11/13/nets-say-levert-could-return-foot-injury-this-season/"/> <meta property="og:title" content="Nets say LeVert could return from foot injury this season"/> <meta itemprop="image" property="og:image" content="http://www.wafb.com/resizer/bYoBad2j0tmWSHYQhoBm8ylbgjU=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/AL37UPABCVGI5BPWG6DVUGYWHY.jpg"/> <meta property="og:description" content="Brooklyn Nets say Caris LeVert won't need surgery for what appeared to be severe foot injury and could return this season"/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="http://www.wafb.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="818561641490966"/> <meta property="fb:pages" content="92786858822"/> <meta property="fb:admins" content="644426401"/> <meta property="article:publisher" content="https://www.facebook.com/Channel9BatonRouge"> <link rel="amphtml" href="/2018/11/13/nets-say-levert-could-return-foot-injury-this-season/?outputType=amp"> <meta name="author" content="BRIAN MAHONEY"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Nets say LeVert could return from foot injury this season",
        
        "image": {
          "@type": "ImageObject",
          "url": "http://www.wafb.com/resizer/bYoBad2j0tmWSHYQhoBm8ylbgjU=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/AL37UPABCVGI5BPWG6DVUGYWHY.jpg",
          "height": 2507.0,
          "width": 1200
        },
        
        "datePublished": "2018-11-13T20:06:36.860Z",
        "dateModified": "2018-11-13T20:03:09.415Z",
        "articleBody": "NEW YORK (AP) — Caris LeVert&#039;s injury wasn&#039;t as bad as it looked.The Brooklyn Nets said Tuesday their leading scorer suffered only a dislocation of his right foot and no fractures, and he could return this season.That&#039;s far better than what was feared when LeVert&#039;s leg appeared to bend in a gruesome manner after he leaped to block a shot in the final seconds of the first half of Monday night&#039;s game in Minnesota.&#034;While the optics of this injury may have appeared to be more severe, surgery will not be required,&#034; team orthopedist Dr. Martin O&#039;Malley said in a statement.O&#039;Malley examined LeVert on Tuesday at the Hospital for Special Surgery and the third-year swingman was diagnosed with a subtalar dislocation of the right foot.Brooklyn Nets guard Caris LeVert (22) is tended to after an injury during the second quarter of an NBA basketball game against the Minnesota Timberwolves on Monday, Nov. 12, 2018, in Minneapolis. (AP Photo/Hannah Foslien)O&#039;Malley said there was only moderate ligament damage and that following a period of rehabilitation, LeVert was expected to return to full strength and resume all basketball activities without any limitations this season.LeVert&#039;s injury initially appeared similar to the severe leg injuries suffered in recent years by Paul George and Gordon Hayward, and players prayed and some were in tears as a stretcher was brought onto the court to take LeVert to a hospital.But he was able to return to New York with the Nets later Monday as players from around the NBA were sending well wishes on social media.LeVert, who battled foot injuries in college at Michigan before emerging as a first-round pick, had been the Nets&#039; best player during their promising start. He is averaging 18.4 points and is the only player in the league this season to convert multiple go-ahead baskets with less than 10 seconds remaining in regulation or overtime.___The Brooklyn Nets watch as teammate guard Caris LeVert, not pictured, is checked on after an injury against the Minnesota Timberwolves during the second quarter of an NBA basketball game on Monday, Nov. 12, 2018, in Minneapolis. (AP Photo/Hannah Foslien)More AP NBA: https://apnews.com/tag/NBA and https://twitter.com/AP_Sports",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "BRIAN MAHONEY"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "",
        "logo": {
          "@type": "ImageObject",
          "url": "http://www./pb/resources/images//logo_meta.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "Brooklyn Nets say Caris LeVert won't need surgery for what appeared to be severe foot injury and could return this season"
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "",
        "url": "http://www.wafb.com",
        "logo": "http://www.wafb.com/pb/resources/images/rm_icons/wafb-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/Channel9BatonRouge" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-frameworkd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/wafb-logo.svg?v=36)}</style> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-frameworkd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-featuresd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <link href="/pb/resources/dist/d404f83286001ac73b19/rm/rm-servicesd404f83286001ac73b19.css?v=36" rel="stylesheet"/> <script async src="/pb/resources/dist/d404f83286001ac73b19/rm/rm-indexd404f83286001ac73b19.js?v=36"></script> <script src="/pb/gr/c/default/rLHRca29un8L8r/arcAdsJS/84612eb819.js?v=36"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="fcoEPa19un8L8r"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wafb.com/ask-the-expert/" class="color-grey-dark">Ask the Expert</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wafb.com/ask-the-attorney" class="color-grey-dark">Ask the Attorney</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.wafb.com/contests/" class="color-grey-dark">Contests and Deals</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="faZ5cp19un8L8r"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full{background-color:#f9f9f9}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0qHT279un8L8r"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.wafb.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.wafb.com/live/" class="">Watch Live</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/traffic" class="">Traffic</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news/investigate" class="">The Investigators</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/health" class="">Health</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.thelouisianaweekend.com" class="">Louisiana Weekend</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/about-us" class="">About Us</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/homepage" class="color-white">Home</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.wafb.com/apps/weather-app/" class="color-white">Download Our Weather App</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.wafb.com/newsapp" class="color-white">Download our News App</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/about-us" class="color-white">About Us</a> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/about-us/9questions" class="color-white">9Questions</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&searchLocation=-12802-Baton+Rouge" class="color-white">Jobs at WAFB</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/programming" class="color-white">Programming</a> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-11"> <a href="http://www.wafb.com/programming/me-time" class="color-white">Me Time With Frangela</a> </li> <li class="list-unstyled padded padded-sm padded-right li-12"> <a href="http://www.wafb.com/programming/cbs-fall" class="color-white">CBS Fall Line-up</a> </li> <li class="list-unstyled padded padded-sm padded-right li-13"> <a href="/programming/schedule" class="color-white">TV Schedule</a> </li> </ul> </li> </ul> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/news" class="color-white">News</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/traffic" class="color-white">Traffic</a> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="https://www.wafb.com/2018/08/30/first-alert-traffic-road-closures/" class="color-white">Road Closures</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/traffic/gas-prices" class="color-white">Gas Prices</a> </li> </ul> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.wafb.com/live" class="color-white">WAFB 9News Live</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/investigate" class="color-white">The Investigators</a> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/news/investigate/alert-team" class="color-white">9News Alert Team</a> </li> </ul> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/news/state" class="color-white">State</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/news/national" class="color-white">National</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="/news/good-news" class="color-white">It's All Good</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/news/crime" class="color-white">Crime</a> </li> <li class="list-unstyled padded padded-sm padded-right li-10"> <a href="/business" class="color-white">Business</a> </li> <li class="list-unstyled padded padded-sm padded-right li-11"> <a href="/politics" class="color-white">Politics</a> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-13"> <a href="https://www.wafb.com/politics/election-results/" class="color-white">Election Results</a> </li> <li class="list-unstyled padded padded-sm padded-right li-14"> <a href="/politics/vote-louisiana" class="color-white">Vote Louisiana</a> </li> </ul> </li> <li class="list-unstyled padded padded-sm padded-right li-12"> <a href="/news/editorial" class="color-white">Editorial</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/news/video" class="color-white">Video</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/community/morning-show-guests" class="color-white">Morning Show Guests</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/community/adopt-a-pet" class="color-white">Adopt A Pet</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/sports/high-school/football/sportsline-friday-nite-videos" class="color-white">Sportline Friday Nite Videos</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/health" class="color-white">Health</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/health/cold-and-flu" class="color-white">Cold and Flu</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/health/exercise-and-fitness" class="color-white">Get Fit Red Stick</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/health/medical-marijuana" class="color-white">Medical Marijuana</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/health/opioid-crisis" class="color-white">Opioid Crisis</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/health/chasing-a-fix" class="color-white">Chasing A Fix</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/weather" class="color-white">Weather</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.wafb.com/weather/#radar" class="color-white">Radar</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/weather/river-stages" class="color-white">River Stages</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/weather/hurricane" class="color-white">Hurricane</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/weather/closings" class="color-white">Closings</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/sports" class="color-white">Sports</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/sports/high-school/football" class="color-white">Sportsline Friday Nite</a> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/sports/high-school/football/throwback-thursday" class="color-white">Throwback Thursday</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/sports/high-school/football/player-of-the-week" class="color-white">Player of the Week</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/sports/high-school/football/scores" class="color-white">Friday Nite Scores</a> </li> </ul> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/sports/ncaa/lsu" class="color-white">LSU</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/sports/ncaa/southern-university" class="color-white">Southern University</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/sports/nfl/saints" class="color-white">Saints</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/sports/nba/pelicans" class="color-white">Pelicans</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/community" class="color-white">Community</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/contests" class="color-white">Contests and Deals</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.thelouisianaweekend.com/?_ga=2.128168204.1459428273.1535149883-815905118.1527635181" class="color-white">Louisiana Weekend</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.wafb.com/community/beat-bama/" class="color-white">Beat Bama Blood Drive</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/community/heart-of-louisiana" class="color-white">Heart of Louisiana</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/community/hand-it-on" class="color-white">Hand It On</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="/community/calendar" class="color-white">Calendar</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/community/user-content" class="color-white">9Reports</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/food/recipe" class="color-white">Recipes</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/food/recipe/breakfast" class="color-white">Breakfast</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/food/recipe/appetizers" class="color-white">Appetizers</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/food/recipe/salad" class="color-white">Salad</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/food/recipe/sides" class="color-white">Sides</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/food/recipe/seafood" class="color-white">Seafood</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="/food/recipe/meat" class="color-white">Meat</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/food/recipe/soup" class="color-white">Soup</a> </li> <li class="list-unstyled padded padded-sm padded-right li-10"> <a href="/food/recipe/pasta" class="color-white">Pasta</a> </li> <li class="list-unstyled padded padded-sm padded-right li-11"> <a href="/food/recipe/sandwiches" class="color-white">Sandwiches</a> </li> <li class="list-unstyled padded padded-sm padded-right li-12"> <a href="/food/recipe/desserts" class="color-white">Desserts</a> </li> <li class="list-unstyled padded padded-sm padded-right li-13"> <a href="/food/recipe/beverages" class="color-white">Beverage</a> </li> </ul> </li> </ul> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0YjPkH9un8L8r"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-wafb-breaking/" data-url="/pb/api/v2/render/feature" data-website="wafb" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fLuQZ619un8L8r"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/wafb-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="wafb"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0gDV5l9un8L8r"> <div id="ad1376-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1376" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1376",slotName:"wafb/web/sports/national",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"MP5YZTV6IJATFOYV5SE2LSEVWI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="fFudHD19un8L8r"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Nets say LeVert could return from foot injury this season</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <img class="width-full " alt="Nets say LeVert could return from foot injury this season" src="http://www.wafb.com/resizer/41TCfx3E7HAkY-WJVxx7q2QGuXk=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/AL37UPABCVGI5BPWG6DVUGYWHY.jpg"/> </div> <div class="container"> <figcaption class="caption-text spaced flex-container-row justify-space-between card card-article"> Brooklyn Nets guard Caris LeVert (22) is tended to after an injury during the second quarter of an NBA basketball game against the Minnesota Timberwolves on Monday, Nov. 12, 2018, in Minneapolis. (AP Photo/Hannah Foslien) (Hannah Foslien) </figcaption> </div> </figure> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0FWvYf9un8L8r"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share flex-container-column text-align-right"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Nets+say+LeVert+could+return+from+foot+injury+this+season&amp;url=http%3A%2F%2Fwww.wafb.com%2F2018%2F11%2F13%2Fnets-say-levert-could-return-foot-injury-this-season%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter icon-light"></i> </button> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.wafb.com%2F2018%2F11%2F13%2Fnets-say-levert-could-return-foot-injury-this-season%2F&amp;title=Nets+say+LeVert+could+return+from+foot+injury+this+season', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square icon-light"></i> </button> <a href="mailto:?subject=Nets%20say%20LeVert%20could%20return%20from%20foot%20injury%20this%20season&amp;body=Read%20more%20on%20Nets%20say%20LeVert%20could%20return%20from%20foot%20injury%20this%20season%20at%20http%3A%2F%2Fwww.wafb.com%2F2018%2F11%2F13%2Fnets-say-levert-could-return-foot-injury-this-season%2F"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <i class="far fa-envelope icon-light"></i> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0ERLyn9un8L8r"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <span class="font-bold color-black">BRIAN MAHONEY</span> <span class="font-bold">|</span> <span class="timestamp"> November 13, 2018 at 2:03 PM CST - Updated November 13 at 2:06 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0vZVE19un8L8r"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>NEW YORK (AP) — Caris LeVert's injury wasn't as bad as it looked.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The Brooklyn Nets said Tuesday their leading scorer suffered only a dislocation of his right foot and no fractures, and he could return this season.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>That's far better than what was feared when LeVert's leg appeared to bend in a gruesome manner after he leaped to block a shot in the final seconds of the first half of Monday night's game in Minnesota.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>"While the optics of this injury may have appeared to be more severe, surgery will not be required," team orthopedist Dr. Martin O'Malley said in a statement.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad225-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad225" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad225",slotName:"wafb/web/sports/national/MP5YZTV6IJATFOYV5SE2LSEVWI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>O'Malley examined LeVert on Tuesday at the Hospital for Special Surgery and the third-year swingman was diagnosed with a subtalar dislocation of the right foot.</p> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Brooklyn Nets guard Caris LeVert (22) is tended to after an injury during the second quarter of an NBA basketball game against the Minnesota Timberwolves on Monday, Nov. 12, 2018, in Minneapolis. (AP Photo/Hannah Foslien)" data-src="http://www.wafb.com/resizer/JdhhMOEDXUV0wscYAO9PpKdCX3Q=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/QGHLWASTQZANZPSMU6WIAAI4DE.jpg" src="http://www.wafb.com/resizer/vjQkb5rX3kWvmsLjkq8kYWPnK8Y=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/QGHLWASTQZANZPSMU6WIAAI4DE.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Brooklyn Nets guard Caris LeVert (22) is tended to after an injury during the second quarter of an NBA basketball game against the Minnesota Timberwolves on Monday, Nov. 12, 2018, in Minneapolis. (AP Photo/Hannah Foslien) (AP) </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>O'Malley said there was only moderate ligament damage and that following a period of rehabilitation, LeVert was expected to return to full strength and resume all basketball activities without any limitations this season.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>LeVert's injury initially appeared similar to the severe leg injuries suffered in recent years by Paul George and Gordon Hayward, and players prayed and some were in tears as a stretcher was brought onto the court to take LeVert to a hospital.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad95-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad95" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad95",slotName:"wafb/web/sports/national",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>But he was able to return to New York with the Nets later Monday as players from around the NBA were sending well wishes on social media.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad550-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad550" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad550",slotName:"wafb/web/sports/national/MP5YZTV6IJATFOYV5SE2LSEVWI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>LeVert, who battled foot injuries in college at Michigan before emerging as a first-round pick, had been the Nets' best player during their promising start. He is averaging 18.4 points and is the only player in the league this season to convert multiple go-ahead baskets with less than 10 seconds remaining in regulation or overtime.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>___</p> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="The Brooklyn Nets watch as teammate guard Caris LeVert, not pictured, is checked on after an injury against the Minnesota Timberwolves during the second quarter of an NBA basketball game on Monday, Nov. 12, 2018, in Minneapolis. (AP Photo/Hannah Foslien)" data-src="http://www.wafb.com/resizer/daWObhVprZCczI4O9FW_e7IbdHs=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/TNYAGUYVSZAR5CM5K6HBNXIWXU.jpg" src="http://www.wafb.com/resizer/xpVqkwo1RTS4lc-8196Y-6PMlaw=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/TNYAGUYVSZAR5CM5K6HBNXIWXU.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> The Brooklyn Nets watch as teammate guard Caris LeVert, not pictured, is checked on after an injury against the Minnesota Timberwolves during the second quarter of an NBA basketball game on Monday, Nov. 12, 2018, in Minneapolis. (AP Photo/Hannah Foslien) (AP) </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p>More AP NBA: https://apnews.com/tag/NBA and https://twitter.com/AP_Sports</p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f0TTvjs9un8L8r"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="http://www.wafb.com/2018/11/13/nets-say-levert-could-return-foot-injury-this-season/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="http://www.wafb.com/2018/11/13/nets-say-levert-could-return-foot-injury-this-season/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fys8K319un8L8r"> <div id="ad710-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad710" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad710",slotName:"wafb/web/sports/national",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"MP5YZTV6IJATFOYV5SE2LSEVWI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="freGbo19un8L8r"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-cloudy" data-default-location-code="USLA0033" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="wafb" data-location-code="USLA0033" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USLA0033,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="http://www.wafb.com/weather"> <img class="radar-image" src="http://webpubcontent.raycommedia.com/wafb/Radar_Web.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="41" data-temp-c="5"> 41</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/67_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Baton Rouge, LA</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="http://www.wafb.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> <div class="flex-container-row justify-center spaced spaced-md spaced-bottom spaced-top font-semi-bold"> <span class="spaced spaced-right spaced-sm">Sponsored By</span> <div id="ad1135-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1135" class="arcad ad-120x30"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1135",slotName:"wafb/web/weather-widget",adType:"weather-sponsorship",dimensions:"[[[120, 30]], [[120, 30]], [[120, 30]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"weather",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="cM0Fe919un8L8r"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fCkDC819un8L8r"> <div class="flex-feature height-full"> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-96376" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2018/11/13/steelers-rb-leveon-bell-no-show-deadline-approaches/"> <img class="width-full " alt="Steelers RB Le'Veon Bell a no-show as deadline approaches" src="http://www.wafb.com/resizer/OOczBjs4Tim-nymv330u5rXx5B4=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/L4W4F56EUVGRNA6YDQTGPLDWZM.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/13/steelers-rb-leveon-bell-no-show-deadline-approaches/"> Steelers RB Le'Veon Bell a no-show as deadline approaches</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Steelers RB Le'Veon Bell a no-show as 4 p.m. deadline approaches</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>WILL GRAVES</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2018/11/13/bilas-college-basketball-players-will-one-day-be-paid/"> <img class="width-full " alt="Bilas: College basketball players will one day be paid" src="http://www.wafb.com/resizer/7vFh8o_qGqQ-xQociyGQt4lG3lQ=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/V4XZD5FGWFDQ3P6QBXV3LXEXZM.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/13/bilas-college-basketball-players-will-one-day-be-paid/"> Bilas: College basketball players will one day be paid</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">College basketball analyst Jay Bilas believes players will eventually be paid, and tells PodcastOne Sports Now that he's not sure top players will forgo a year on the big stage in college to play in the NBA's developmental league</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>The Associated Press</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0h4rOa9un8L8r"> <div id="ad1741-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1741" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1741",slotName:"wafb/web/sports/national",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"MP5YZTV6IJATFOYV5SE2LSEVWI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="ccTus119un8L8r"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="f0w9vQraun8L8r"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-71955" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/13/anderson-thrashes-nishikori-be-verge-atp-semis/"> <img class="width-full " alt="Anderson thrashes Nishikori to be on verge of ATP semis" src="http://www.wafb.com/resizer/T45JFE8c7XHPb-HCTvKdlDMOdpM=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/5TWYORK3HVDWTET3274N7PHSPI.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/13/anderson-thrashes-nishikori-be-verge-atp-semis/"> Anderson thrashes Nishikori to be on verge of ATP semis</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>SAM JOHNSTON</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 4h at 10:13 AM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/13/hue-jackson-back-cincinnati-helping-run-defense/"> <img class="width-full " alt="Hue Jackson back in Cincinnati, helping to run defense" src="http://www.wafb.com/resizer/roB5LUNYv4MrAYJe5OiSgk_yNi4=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/JYB2QQ3BKZAYXAYDEUX5PKZS5U.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/13/hue-jackson-back-cincinnati-helping-run-defense/"> Hue Jackson back in Cincinnati, helping to run defense</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>JOE KAY</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 5h at 8:58 AM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/13/thailand-child-boxing-debated-after-year-old-death/"> <img class="width-full " alt="Thailand's child boxing debated after 13-year-old's death" src="http://www.wafb.com/resizer/T1Q2Nr-mmmTkBI7mENNljGqlkC4=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/PF6E5QWR2JDWRBHVOEQXJL7GFQ.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/13/thailand-child-boxing-debated-after-year-old-death/"> Thailand's child boxing debated after 13-year-old's death</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Bt KAWEEWIT KAEWJINDA AND TASSANEE VEJPONGSA</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 8:08 AM at 8:08 AM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2018/11/13/japan-rallies-beat-mlb-all-stars-lead-series-/"> <img class="width-full " alt="Japan rallies to beat MLB All-Stars 5-3 to lead series 3-1" src="http://www.wafb.com/resizer/MnyqdN8_IhDz5gi_f5d7q1H99qU=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/7GXMHOPOCBDDJAMFVSZA5OOIQ4.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2018/11/13/japan-rallies-beat-mlb-all-stars-lead-series-/"> Japan rallies to beat MLB All-Stars 5-3 to lead series 3-1</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>JIM ARMSTRONG</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 7:59 AM at 7:59 AM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fhRf1A1aun8L8r"> <div id="ad1724-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1724" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1724",slotName:"wafb/web/sports/national",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"MP5YZTV6IJATFOYV5SE2LSEVWI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="f2VEMZ1aun8L8r"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.wafb.com"> <div class="logo logo-slim"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 844 Government Street<br/>Baton Rouge, LA 70802<br/>(225) 383-9999 </p> <a class="call-to-action uppercase color-white" href="http://www.wafb.com/about-us">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wafb" class="color-white">WBXH FCC Public File</a></li> <li><a href="mailto:publicfile@wafb.com" class="color-white">publicfile@wafb.com<br/>(225) 215-4703</a></li> <li><a href="http://webpubcontent.raycommedia.com/wafb/EEO/EEO%20PUBLIC%20FILE%202018.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.wafb.com/story/12183706/closed-captioning-concerns/" class="color-white">Closed Captioning</a></li> <li><a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&searchLocation=-12802-Baton+Rouge" class="color-white">WAFB Careers</a></li> <li><a href="http://www.wafb.com/2018/08/24/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.wafb.com/2018/08/24/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/WAFB" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/Channel9BatonRouge" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wafb" class="color-white">WBXH FCC Public File</a></li> <li><a href="mailto:publicfile@wafb.com" class="color-white">publicfile@wafb.com<br/>(225) 215-4703</a></li> <li><a href="http://webpubcontent.raycommedia.com/wafb/EEO/EEO%20PUBLIC%20FILE%202018.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.wafb.com/story/12183706/closed-captioning-concerns/" class="color-white">Closed Captioning</a></li> <li><a href="http://careers-raycommedia.icims.com/jobs/search?ss=1&searchLocation=-12802-Baton+Rouge" class="color-white">WAFB Careers</a></li> <li><a href="http://www.wafb.com/2018/08/24/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.wafb.com/2018/08/24/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/WAFB" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/Channel9BatonRouge" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rLHRca29un8L8r/render.js?v=36'></script>